View Single Post
  #1  
Unread 18th March, 2008, 09:35 PM
kewlazme kewlazme is offline
Forum Newcomer
 
Join Date: Jul 2003
Posts: 6
Default Starting a Mod server with batch file?

I am trying to start a server for a ut3 mod from a command line and getting completely different results than when I start it from within the game.

When I start the dedicated server from within the game, the server console shows:
Code:
Log: Game class is 'MyModGameInfo'
When I start the dedicated server from the batch file, the server console shows:
Code:
Log: Game class is 'DemoGame'
After this point in the console, the output changes quite a bit. I can run the default UT3 gametypes from the batch file just fine but for mods it loads this "DemoGame" class instead of the specified game class.

When it loads the "DemoGame" class it shows some other info later on about how it can't find a server reg for DemoGame and the server will not be advertised. But I can't even connect to it locally from my own pc when i type in the full address (i can when starting the server from within the game).. so I think the server itself isn't even actually broadcasting.

My batchfile is:
Quote:
ut3.exe server DS-DarkSect?MaxPlayers=16?bShouldAdvertise=True?bUsesStats=Tr ue?bAllowJoinInProgress=True?bIsDedicated=True?CustomMapName=DS-DarkSect?CustomGameMode=DSMod.DSGameInfo?Goa
lScore=20?TimeLimit=20?ServerDescription=0000?game=DSMod.DSGameInfo -log=DedicatedServer.log -Login=xxxx Password=xxxx
Is there some other -mod switch needed for this to work? Or are mod servers not supported from Command line yet?

Last edited by kewlazme : 18th March, 2008 at 09:37 PM.
Reply With Quote