You are an unregistered user, you can register here
Navigation

Information

Site

Donations
If you wish to make a donation you can by clicking the image below.


BeyondUnreal News

 
Go Back   The Unreal Admins Page > Forums > Hosted Forums > Universal Unreal

Reply
Thread Tools Display Modes
  #1  
Unread 27th April, 2010, 05:54 PM
[G4U]The_Sp00nHead [G4U]The_Sp00nHead is offline
Rampage
 
Join Date: Jul 2008
Posts: 57
Default Strange problem (UU111)

Hi all,

This problem is starting to drive me insane,

Firstly version numbers .....
UniversalUnreal 1.11
MySQL Version 5.1.37
PHP Version 5.3.0

I have setup a universe http://www.g4ucommunity.co.uk/UniversalUnreal/
After installation I went to the site and signed up
to get the first admin signup.
When I did this I filled out the signup form and clicked OK
and I the just got a white page ..... Thats it !?!

It did create the user as I have found it in the database,
So I try and log in ....... type correct user & pass into site
and again I just get white page !?!?!

I can navigate round the rest of the site no prob,
I have other php -> mysql connections running fine
(PHPBB3 - UTstats and more) they all run a-ok.

Can anyone shed any light on this as I really want
to get this up and running to connect the [G4U] servers
together, so members know who is playing where (even
ingame )

thanks in advance !!

Sp00neY
__________________
Reply With Quote
  #2  
Unread 28th April, 2010, 10:51 PM
Matthew Matthew is offline
Holy Shit!!
 
Join Date: Dec 2004
Posts: 2,382
Default

Very odd indeed. Can you post your constants.php file? Remember to remove MySQL connection info and your universe password.
Reply With Quote
  #3  
Unread 28th April, 2010, 11:11 PM
[G4U]The_Sp00nHead [G4U]The_Sp00nHead is offline
Rampage
 
Join Date: Jul 2008
Posts: 57
Default

No problem Matthew,

PHP Code:
<?php
/**
 * Database Constants - these constants are required
 * in order for there to be a successful connection
 * to the MySQL database. Make sure the information is
 * correct.
 */
define("DB_SERVER""localhost");
define("DB_USER""REMOVED");
define("DB_PASS""REMOVED");
define("DB_NAME""REMOVED");

/**
 * The universe name and password; you must give this
 * to participating servers before they can connect to this installation.
 * Be descriptive with the Universe ID. For example, if your community
 * is called "Sniper Alliance", this would also be a good Universe ID.
 * DO NOT USE SIMPLE NAMES LIKE 'universe', 'unreal', 'ut', 'server',
 * etc etc - you need to be specific!!!
 */
define("UNIVERSE_ID""games4u");
define("UNIVERSE_PASS""REMOVED");

/**
 * The primary admin of this installation, the name and e-mail
 * address will be displayed to users
 */
define("UNIVERSE_ADMIN_NAME""[G4U]The_Sp00nHead");
define("UNIVERSE_ADMIN_EMAIL""[email protected]");

// you must correctly enter the world-viewable URL to this installation, and it *MUST END IN A FORWARD SLASH!*
define("UNIVERSE_URL""http://www.g4ucommunity.co.uk/UniversalUnreal/");

// welcome message on the front page, change to define("PORTAL_MSG", ""); to disable
define("PORTAL_MSG""Welcome to our new installation of Universal Unreal!");

/**
 * Log Player Data - if you wish to have Universal Unreal
 * save data from participating servers about player
 * joins, administrative actions, etc, set this True
 */
define("LOG_PLAYER_DATA",True);

/**
 * Email Constants - these specify what goes in
 * the from field in the emails that Universal Unreal
 * sends to users
 */
define("EMAIL_FROM_NAME""Games 4 U Universe");
define("EMAIL_FROM_ADDR""[email protected]");

/**
 * SMTP Constants - by default, Universal Unreal
 * uses PHP's built-in mail() function for sending e-mail.
 * Should you need to use SMTP for sending mail,
 * set SMTP_USE to True and and fill in
 * the appropriate information.
 */
define("SMTP_USE",False);
define("SMTP_HOST""mail.myhost.com");
define("SMTP_PORT"25);
define("SMTP_USERNAME","someuser");
define("STMP_PASSWORD","somepass");

/**
 * Some web server hosting companies don't allow
 * what is called 'url fopen' for their own security.
 * However, this is the primary way that Universal Unreal
 * transmits data. If your host has the cURL libraries
 * installed, Universal Unreal can use these instead.
 * Set QUERY_METHOD to 0 to use url fopen,
 * and if you have issues try setting QUERY_METHOD
 * to 1 to use cURL instead (if installed)
 */
define("QUERY_METHOD",0);

// =========================================================================
// Do not edit below this line unless you know exactly what you are doing!
// =========================================================================





/**
 * Timeout Constants - these constants refer to
 * the maximum amount of time (in minutes) after
 * their last page fresh that a user and guest
 * are still considered active visitors. We
 */
define("USER_TIMEOUT"5);
define("GUEST_TIMEOUT"5);

/**
 * Cookie Constants - these are the parameters
 * to the setcookie function call, change them
 * if necessary to fit your website. If you need
 * help, visit www.php.net for more info.
 * <http://www.php.net/manual/en/function.setcookie.php>
 */
define("COOKIE_EXPIRE"60*60*24*180);  //180 days by default
define("COOKIE_PATH""/");  //Avaible in whole domain

// Version 111, Build 01
define("BUILD","11101");
?>
this is slownly driving me insane, i have checked and
double checked everything I can think of.
If it will help i'll PM you with a link to a phpinfo script
on the same webserver.

Thanks for replying m8,

Sp00neY
__________________
Reply With Quote
  #4  
Unread 27th May, 2010, 10:04 AM
face's Avatar
face face is offline
Holy Shit!!
 
Join Date: Apr 2006
Posts: 524
Default

I tried to register yep white page.
I tried again to login and as soon as you do it leads you back to process.php instead of the index.php.

Can u try to reupload the process.php file again in the include folder?

Might be that during uploading that file got damaged or corrupted and does not do his work properly.
__________________
Reply With Quote
  #5  
Unread 28th May, 2010, 12:33 PM
[G4U]The_Sp00nHead [G4U]The_Sp00nHead is offline
Rampage
 
Join Date: Jul 2008
Posts: 57
Default

OK,

I have done a fresh install of UU (including eraseing the DB and starting
again from scratch).
I have installed it on a RDC so I downloaded UU directly to the server
and set it all up from there,

Still I have the same problem !!

I think I'm gonna pull my hair out, I can't figure this one out at all !?!

Sp00neY
__________________
Reply With Quote
  #6  
Unread 28th May, 2010, 03:15 PM
Matthew Matthew is offline
Holy Shit!!
 
Join Date: Dec 2004
Posts: 2,382
Default

What versions of PHP and MySQL are you using?
Reply With Quote
  #7  
Unread 28th May, 2010, 04:05 PM
[G4U]The_Sp00nHead [G4U]The_Sp00nHead is offline
Rampage
 
Join Date: Jul 2008
Posts: 57
Default

Quote:
Originally Posted by [G4U]The_Sp00nHead View Post
Firstly version numbers .....
UniversalUnreal 1.11
MySQL Version 5.1.37
PHP Version 5.3.0

As I posted in my first post bud, I havnt changed that

Sp00neY
__________________
Reply With Quote
  #8  
Unread 28th May, 2010, 04:43 PM
Matthew Matthew is offline
Holy Shit!!
 
Join Date: Dec 2004
Posts: 2,382
Default

Okay. I'll try to get a web server set up in VMWare with those specs and I'll see what happens.

What distro of Linux?
Reply With Quote
  #9  
Unread 28th May, 2010, 06:50 PM
[G4U]The_Sp00nHead [G4U]The_Sp00nHead is offline
Rampage
 
Join Date: Jul 2008
Posts: 57
Default

Not running linux bud, its on a windows box,
running XAMPP to give apache etc.

(both my Sp00neY's Place and The Games 4 U Community
sites are on the same box.)

As I said before if its any help I can PM you a link to a phpinfo.

Any help warmly welcomed !!

Sp00neY
__________________
Reply With Quote
  #10  
Unread 28th May, 2010, 08:10 PM
Matthew Matthew is offline
Holy Shit!!
 
Join Date: Dec 2004
Posts: 2,382
Default

Quote:
Originally Posted by [G4U]The_Sp00nHead View Post
Not running linux bud, its on a windows box,
running XAMPP to give apache etc.

(both my Sp00neY's Place and The Games 4 U Community
sites are on the same box.)

As I said before if its any help I can PM you a link to a phpinfo.

Any help warmly welcomed !!

Sp00neY
Hrm that could be a reason why... Apache and PHP ports for Windows often have features that behave differently than the Linux versions. What version of Windows?

And sure, go ahead and PM me a URL for a phpinfo file.
Reply With Quote
  #11  
Unread 15th June, 2010, 07:50 PM
2399Skillz 2399Skillz is offline
Super Moderator
 
Join Date: Jan 2004
Location: North Carolina
Posts: 2,242
Default

Sounds like a paths/permissions issue.
__________________

UT-FILES.COM
Get your files
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 07:50 PM.


 

All pages are copyright The Unreal Admins Page.
You may not copy any pages without our express permission.