You are an unregistered user, you can register here
Navigation

Information

Site

Donations
If you wish to make a donation you can by clicking the image below.


Site Sponsor

BeyondUnreal News

 
Go Back   The Unreal Admins Page > Forums > Hosted Forums > UTPure > DarkByte's Mods > SemiAdmin

Reply
Thread Tools Display Modes
  #1  
Unread 15th November, 2002, 09:27 PM
Evolution
 
Posts: n/a
Default

It is doing this because the application that processes images on the server (UTServerAdmin.UTImageServer) also checks for a username & password. It is not compatible with SemiAdmin, and should be disabled. Change the following line in the server's .ini file:

Applications[1]=UTServerAdmin.UTImageServer

to

Applications[1]=UWeb.ImageServer
Reply With Quote
  #2  
Unread 22nd July, 2004, 06:29 PM
Azura's Avatar
Azura Azura is offline
Holy Shit!!
 
Join Date: Apr 2003
Posts: 4,020
Default

That's odd because XMaps doesn't have this problem. It'd be interesting to see what's been done differently.
__________________
How to feck up a perfectly good game:
UT (1999) = UnbelievableGameSoCoolIMustHelpBringNewPlayers Tournament
UT (2008) = Unreal ThrustMyPrivatePartsInYourFaceBish

And that's probably why UTIII was a relative flop. New game, same sh*thead players ^^.
Reply With Quote
  #3  
Unread 22nd July, 2004, 07:59 PM
widowmaker's Avatar
widowmaker widowmaker is offline
Dominating
 
Join Date: May 2003
Location: USA
Posts: 144
Default

ah no wonder, i ended up removing semi admin and installing advanced admin, then just for the hell of it installed semi admin again and it fixed it.

yep changing that fixed it, now can use it without advanced admin being installed.
__________________

Last edited by widowmaker : 22nd July, 2004 at 08:29 PM.
Reply With Quote
  #4  
Unread 22nd July, 2004, 10:08 PM
Azura's Avatar
Azura Azura is offline
Holy Shit!!
 
Join Date: Apr 2003
Posts: 4,020
Default

If only that fix would work on our server . Any suggestions as to anything I might have missed ?
__________________
How to feck up a perfectly good game:
UT (1999) = UnbelievableGameSoCoolIMustHelpBringNewPlayers Tournament
UT (2008) = Unreal ThrustMyPrivatePartsInYourFaceBish

And that's probably why UTIII was a relative flop. New game, same sh*thead players ^^.
Reply With Quote
  #5  
Unread 24th July, 2004, 01:54 AM
PurplePants PurplePants is offline
Rampage
 
Join Date: Dec 2002
Location: Uk.gif
Posts: 53
Default

Quote:
XMaps doesn't have this problem
That's because XMaps doesn't store its images in the same place. In unrealtournament.ini you'll have this entry:

ApplicationPaths[0]="/images"

What that says to UT is "anything accessing the /images directory gets handled by Application[0]", which is UTImageServer. XMaps images are in the XMaps subdirectory, so get handled by XMaps.

ImageServer looks at the file type requested and sends the appropriate HTML images/jpg (or whatever) headers then the file.

The difference that UTImageServer adds is to check the username and password before allowing the request to be processed.
Reply With Quote
  #6  
Unread 24th July, 2004, 02:30 AM
Azura's Avatar
Azura Azura is offline
Holy Shit!!
 
Join Date: Apr 2003
Posts: 4,020
Default

Thanks for clearing that up Purple . I think I'm going to edit the html files so this problem doesn't occur again.
__________________
How to feck up a perfectly good game:
UT (1999) = UnbelievableGameSoCoolIMustHelpBringNewPlayers Tournament
UT (2008) = Unreal ThrustMyPrivatePartsInYourFaceBish

And that's probably why UTIII was a relative flop. New game, same sh*thead players ^^.
Reply With Quote
  #7  
Unread 24th July, 2004, 02:50 PM
PurplePants PurplePants is offline
Rampage
 
Join Date: Dec 2002
Location: Uk.gif
Posts: 53
Default

I'd suggest you take evolutions advice and replace UTImageServer with ImageServer. The reason for that is because otherwise you have to move all the stuff in /images somewhere else, and then change all the webadmin stuff that might refer to those images (OPBan, MVR, etc). Simpler just to whip 'UT' off
Reply With Quote
  #8  
Unread 24th July, 2004, 08:11 PM
Azura's Avatar
Azura Azura is offline
Holy Shit!!
 
Join Date: Apr 2003
Posts: 4,020
Default

That's the way I've set up things at the moment but sometimes I get some rather odd behaviour. For example, I was logged into ServerAdmin (the standard web admin) and clicked on the console link and the login box popped up again.
__________________
How to feck up a perfectly good game:
UT (1999) = UnbelievableGameSoCoolIMustHelpBringNewPlayers Tournament
UT (2008) = Unreal ThrustMyPrivatePartsInYourFaceBish

And that's probably why UTIII was a relative flop. New game, same sh*thead players ^^.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 08:48 AM.


Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

All pages are copyright The Unreal Admins Page.
You may not copy any pages without our express permission.