You are an unregistered user, you can register here
Navigation

Information

Site

Donations
If you wish to make a donation you can by clicking the image below.


Site Sponsor

BeyondUnreal News

 
Go Back   The Unreal Admins Page > Forums > Hosted Forums > UTPure > UTPure - Client Side Hack Protection > General Anti-Cheat Discussion

Reply
Thread Tools Display Modes
  #1  
Unread 25th September, 2007, 10:46 PM
TheWatcher TheWatcher is offline
Unstoppable
 
Join Date: Jun 2007
Posts: 205
Default UTPure bug (warmup + disablepure)

There is a bug with utpure warmup mode. After mutate disablepure and restart map the jumpz of player is not the normal value. This is problem when you want to play gametype or mod not compatible with pure.
Reply With Quote
  #2  
Unread 26th September, 2007, 03:29 PM
NuFF$@iD NuFF$@iD is offline
Unstoppable
 
Join Date: May 2004
Location: UK
Posts: 235
Default

no point reporting it since the pure team no longer maintain the mod.
Neither have they released the source so otheres can carry it on like cshp did.
theres bugs in the zp code also that pure has. either shoot through which realy isent shoot through just utpure messing up. aim to the side and you will hit them. also in wars it sux when you get the dreaded purezp bug where you shoot the opponent back and cannot kill them.
But like i said No one cares, either live with the unfinished mod or dont use it. choice is yours
Reply With Quote
  #3  
Unread 26th September, 2007, 09:44 PM
TheWatcher TheWatcher is offline
Unstoppable
 
Join Date: Jun 2007
Posts: 205
Default

Quote:
Originally Posted by NuFF$@iD View Post
But like i said No one cares, either live with the unfinished mod or dont use it. choice is yours
this is not the problem. the problem is that the server have utpure for clan war but there is a gametype for pug that is not compatible with pure. this is why admin must disable pure. for this i think i will make a serverside mutator that will do this automatic. also maybe it is possible to reset jumpz?
Reply With Quote
  #4  
Unread 21st October, 2007, 07:53 PM
nogginBasher nogginBasher is offline
Dominating
 
Join Date: Jun 2005
Location: Bristol UK
Posts: 125
Default

I ended up using ServerMode to enable Pure for clanwars, and disable it for Siege games:

Commands[11]=SET UTPureRC7G.UTPure bUTPureEnabled False
Commands[12]=SET PureStat7G.PureStat bEnabled False

I think the annoying physics change is not the fault of Pure, but of Siege, since CTF games work fine. The Siege physics feel a bit like Pure's warmup, which is Classic as opposed to Hardcore game-style. Still haven't worked out how to fix it.
__________________
[ UT servers: XOL DOG 400 CTF | .nzp CTF/LMS/Siege (nB+evil_bill) | RIP ELMS | wHartHog's PigPen crazy CTF ]

Reply With Quote
  #5  
Unread 21st October, 2007, 10:41 PM
[BSC]MasterJohnny [BSC]MasterJohnny is offline
Holy Shit!!
 
Join Date: Apr 2005
Location: Hajdúszoboszló, Hungary
Posts: 823
Default

You can try using it with Dynamic Package Loader. Worked good for me.
Reply With Quote
  #6  
Unread 22nd October, 2007, 01:51 PM
TheWatcher TheWatcher is offline
Unstoppable
 
Join Date: Jun 2007
Posts: 205
Default

it is install on the smiling monsters server but it detect map type and not gametype. the server use ctf gametype and siege gametype. i will try to modify dynamicpackageloader mod for this problem.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 10:34 PM.


Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

All pages are copyright The Unreal Admins Page.
You may not copy any pages without our express permission.