You are an unregistered user, you can register here
Navigation

Information

Site

Donations
If you wish to make a donation you can by clicking the image below.


Site Sponsor

BeyondUnreal News

 
Go Back   The Unreal Admins Page > Forums > Hosted Forums > Wormbos Area > Bugs

Reply
Thread Tools Display Modes
  #21  
Unread 24th April, 2007, 09:48 AM
UltraCool UltraCool is offline
Forum Newcomer
 
Join Date: Apr 2007
Posts: 12
Default

did anyone report yet about the spinning bug?

when you spawn you're spinning around and are not able to see anything because everything just goes to fast... it's a Antitcc bug thats known by players for a while, but i could not find it here anywhere...

our server is running latest antitcc 1.19 beta 26.
Reply With Quote
  #22  
Unread 13th February, 2008, 09:58 PM
JiveMiguel's Avatar
JiveMiguel JiveMiguel is offline
Killing Spree
 
Join Date: May 2004
Location: Sunny Southern California
Posts: 19
Default

I noticed a weird thing on my VCTF server. I am running AntiTCC119Beta26 and a few other mutators. When moving from one seat in a vehicle to another (like going from seat 1 in the hellbender to seat 3 in the hellbender), that the turret would be pointing up at the sky. I'd adjust the angle of the turret, move back to seat 1, then back to seat 3, and again, pointing up. This would happen with seat 2 in the hellbender and seat 2 in the goliath, seat 2 in the SPMA, etc.

I thought it was some other mutator so I stripped them all out. No problems with no mutators. Then I put the mutators back in, one at a time. Since AntiTCC is pretty important, I put it back first and encountered the problem. I was surprised it was AntiTcc, so I did some research. I fixed the problem by disabling the "Rotation lock" option, per wormbo's original post (above), although he's referring to a different problem (I think).

So, set this line like this:
bRotationLock=False
and the problem goes away.

I just wanted to post this here for anyone else who may encounter this problem. It had me stumped for a long time. I know ut2k4 is an older game, but a lot of diehards still play it!
Good luck!
Reply With Quote
  #23  
Unread 14th January, 2009, 08:23 PM
Exje Exje is offline
Forum Newcomer
 
Join Date: Jan 2009
Posts: 3
Question Bug or not?

Hello there,

well im new here. And first of all i wanna say: Nice work!!!

But we have a problem on our server. If the new Anti TCC is running on our server,

we cant log in as a admin in game. Is that normal or is it a bug??

Greets, Exje
Reply With Quote
  #24  
Unread 14th January, 2009, 08:59 PM
JiveMiguel's Avatar
JiveMiguel JiveMiguel is offline
Killing Spree
 
Join Date: May 2004
Location: Sunny Southern California
Posts: 19
Default

Exje,
Are you sure you're not logged in? I don't think anti tcc manages logins, but it does have a silent login feature that I've never been able to confirm whether it works or not. Make sure you're using the correct user and pass and try to add bots with this command:

admin addbots 4

If this works, 4 bots will join and you'll know that you're logged in.

Good luck!
Reply With Quote
  #25  
Unread 14th January, 2009, 09:06 PM
Exje Exje is offline
Forum Newcomer
 
Join Date: Jan 2009
Posts: 3
Default

Well I will check it out on our private server with some other admins.

I will let you know soon. Thanks for the quick feedback.
Reply With Quote
  #26  
Unread 14th January, 2009, 09:45 PM
Exje Exje is offline
Forum Newcomer
 
Join Date: Jan 2009
Posts: 3
Default

One of our admins figured it out.

He sad:

antiTCC does not allow "set input" commands. and that's normal. forgot about that.


So i think we are able to fix it.

Thank you !!
Reply With Quote
  #27  
Unread 15th January, 2009, 11:19 AM
Wormbo's Avatar
Wormbo Wormbo is offline
out of order
 
Join Date: Sep 2003
Posts: 3,383
Default

The "set input" thing is a bug that will be fixed in the next release. In the meantime use "set engine.input" instead, that's the thing, but shouldn't get blocked.
__________________
Wormbo's UT/UT2004/UT3 mods | PlanetJailbreak | Unreal Wiki | Liandri Archives
Quote:
<@Mych|Lockdown> ...and the award for the most creative spelling of "Jailbreak" goes to ... "Gandis Jealbrake Server"
Reply With Quote
  #28  
Unread 23rd April, 2009, 08:06 PM
aCruceSalus aCruceSalus is offline
Forum Newcomer
 
Join Date: Oct 2007
Posts: 2
Default Latest AntiTCC breaks Mutator

Hi Wormbo,
I installed your latest AntiTCC mutator and now the zoom does not work for our GolaithCannon Mutator. How would I go about finding what the incompatibility is so I can fix the mutator? FYI, I don't have "Lock FOV" checked in Web Admin.
Thanks
-Cruce

Last edited by aCruceSalus : 23rd April, 2009 at 08:13 PM.
Reply With Quote
  #29  
Unread 24th April, 2009, 09:44 AM
Wormbo's Avatar
Wormbo Wormbo is offline
out of order
 
Join Date: Sep 2003
Posts: 3,383
Default

Regardless of the Lock FOV setting, Anti TCC checks the various FOV variables for consistency. For example, if you just change the FOV directly, Anti TCC will see an inconsistency with the ZoomLevel variable and reset the FOV.
Make sure your mutator's zoom works similarly to the built-in zooming functions.
__________________
Wormbo's UT/UT2004/UT3 mods | PlanetJailbreak | Unreal Wiki | Liandri Archives
Quote:
<@Mych|Lockdown> ...and the award for the most creative spelling of "Jailbreak" goes to ... "Gandis Jealbrake Server"
Reply With Quote
  #30  
Unread 5th February, 2011, 04:39 PM
kynikos kynikos is offline
Forum Newcomer
 
Join Date: Feb 2011
Posts: 2
Default Anti TCC + Linux 64bit: long freeze during verification

Hi Wormbo, I don't understand if to submit a bug I have to start a new thread or append it to this discussion, I've chosen the latter as you can see.

This is about Anti TCC for UT2004 client side (I only tested version 2009r6) and seems to affect all 64bit Linux (any distro) clients: what happens is that when I connect to a server that embeds Anti TCC I experience quite long freeze periods (30 seconds up to more than 1 minute, and yes, I mean complete freeze, not just a slow down) during the Anti TCC check, precisely during "verifying classes" or "verifying your client" (depending on how Anti TCC is set on the server I think) operation; after that the game runs flawlessly. Sometimes those long freezes make me get even kicked for idling.

This issue has been tested on:
Arch Linux 64bit
Ubuntu 10.10 64bit
Debian Squeeze 64bit
Debian Sid 64bit

These are the discussions I've started to see if anybody else can reproduce the problem:
http://ubuntuforums.org/showthread.php?t=1681680
http://forums.beyondunreal.com/showthread.php?t=194780
At the moment 1 other user besides me reports the same behaviour; nobody reports correct functioning on Linux 64bit.

Steps to reproduce are just:
1) clean install of any 64bit linux distro (at least among the tested ones) with all necessary modules (drivers) and libraries installed to play UT2k4;
2) clean install of UT2k4;
3) 3369 patch installation and modification to the executable script to launch the 64bit version;
4) connection to any server with Anti TCC (only tested 2009r6).

I tested this thing on Ubuntu 10.10 32bit and everything runs fine.

This bug may be more evident (the freeze should take longer) on slower computers, as it's likely related to the checksum creation of installed files, which involves CPU and HDD speed.

Of course I'm willing to do any testing you ask me to.

Thank you!
Reply With Quote
  #31  
Unread 8th February, 2011, 12:12 PM
kynikos kynikos is offline
Forum Newcomer
 
Join Date: Feb 2011
Posts: 2
Default

As Anti TCC seems not to be maintained any longer, for those reading here with the same problem, the next-best workaround is to launch the 32-bit version of UT2004 from your 64-bit system by installing 32-bit libraries: this has no impact at all on the game performance, so have no fear.
In Arch Linux 64, the libraries to install are: (for other distros, the names could vary)

lib32-sdl
lib32-libstdc++5
lib32-nvidia-utils (this is for NVidia cards, if you have an ATI card or you use another driver anyway, you have to install the analogous 32-bit version of this package, if applicable)
lib32-alsa-oss
lib32-openal

But this is not enough, you have to link the 32-bit libSDL and openal into the ...ut2004/System/ directory: (here I suppose you have installed the game in ~/.ut2004/) (the lib32 path could change depending on your distro)

$ mv ~/.ut2004/System/libSDL-1.2.so.0 ~/.ut2004/System/libSDL-1.2.so.0.backup
$ mv ~/.ut2004/System/openal.so ~/.ut2004/System/openal.so.backup
$ ln -s /usr/lib32/libSDL-1.2.so.0 ~/.ut2004/System/libSDL-1.2.so.0
$ ln -s /usr/lib32/libopenal.so ~/.ut2004/System/openal.so

Lastly, don't forget to edit your .../ut2004/ut2004 script to launch the 32-bit executable inside System directory (thus actually restoring it to default).
Now you should be done, enjoy!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 01:19 AM.


Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

All pages are copyright The Unreal Admins Page.
You may not copy any pages without our express permission.