You are an unregistered user, you can register here
Navigation

Information

Site

Donations
If you wish to make a donation you can by clicking the image below.


Site Sponsor

BeyondUnreal News

 
Go Back   The Unreal Admins Page > Forums > Unreal Admins > Unreal Tournament 3 > UT3 Server - Linux Specific

Reply
Thread Tools Display Modes
  #1  
Unread 17th May, 2009, 08:21 PM
jsmith6 jsmith6 is offline
Forum Newcomer
 
Join Date: May 2009
Posts: 2
Default webadmin dies to start on Slackware, but starts on Debian

I am running the UT3 dedicated 2.1 (patch 2.1 came out a few days ago) under Slackware 12.2. I have tried joining games inside the LAN and works fine.

My next step was to add the webadmin package. I have installed it successfully, set bEnable=True and used my custom (non-priviledged) port. Here is my UTWeb.ini:

Quote:
[UWeb.WebServer]
ListenPort=8001
bEnabled=true
Problem is I keep recieving the message that I must enable bEnabled:

Quote:
ScriptLog: Webserver is not enabled. Set bEnabled to True in Advanced Options.
ScriptLog: Destroying WebServer
To make sure I haven't done anything wrong, I rsync'ed the whole UT3 directory in a Debian Squeeze box, and the webadmin UI runs fine:

Quote:
ScriptLog: Web Server Created http://10.0.0.2:8001 Port: 8001 MaxCon 18 ExpirationSecs 86400 Enabled True
Log: GConfig::Find has loaded file: ..\UTGame\Localization/int/WebAdmin.int
WebAdmin: Starting UT3 WebAdmin v1.12 - 2009-03-09 21:20:43 +0000
WebAdmin: Creating IWebAdminAuth instance from: BasicWebAdminAuth
WebAdmin: Creating ISessionHandler instance from: SessionHandler
WebAdmin: Updating news...
WebAdmin: Unable to find query handler class: WebAdmin.WebAdminSystemSettings
So to sum it, the exact same settings run on Squeeze but not on Slackware.

First I tried to open all ports, and disabled any services I could (httpd, gpm, acpid, sshd, etc). No luck. Next I tried an older version of webadmin (a stable one, just older), but again, nothing.

How can I make webadmin work on Slackware?
Reply With Quote
  #2  
Unread 18th May, 2009, 11:28 AM
Wormbo's Avatar
Wormbo Wormbo is offline
out of order
 
Join Date: Sep 2003
Posts: 3,383
Default

If it says "Webserver not enabled" even though you set bEnabled=True in your INI, that most likely means it's using the wrong INI file.
__________________
Wormbo's UT/UT2004/UT3 mods | PlanetJailbreak | Unreal Wiki | Liandri Archives
Quote:
<@Mych|Lockdown> ...and the award for the most creative spelling of "Jailbreak" goes to ... "Gandis Jealbrake Server"
Reply With Quote
  #3  
Unread 20th May, 2009, 01:42 AM
jsmith6 jsmith6 is offline
Forum Newcomer
 
Join Date: May 2009
Posts: 2
Default

After I read your message I grep'ed all .ini files to see in how many files bEnabled gets set. It's only in DefaultWeb.ini and UTweb.ini. I tried deleting DefaultWeb.ini just in case the game reads bEnabled from there, but again it didn't worked.

After some more frustration, I finaly thought searching ~/.* files, and there it was ~/.Unreal Tournament 3! I thought they would use ~/.ut3, but, oh well.

The file ~/.Unreal Tournament 3/UTGame/Config/UTWeb.ini overrides every other file for setting bEnabled. Changed the option there, restarted the server, and voila! the webadmin works like a charm.

Thanks a bunch man!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 09:23 AM.


Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

All pages are copyright The Unreal Admins Page.
You may not copy any pages without our express permission.