You are an unregistered user, you can register here
Navigation

Information

Site

Donations
If you wish to make a donation you can by clicking the image below.


Site Sponsor

BeyondUnreal News

 
Go Back   The Unreal Admins Page > Forums > Unreal Admins > Unreal Tournament > UT Server - General Chat

Reply
Thread Tools Display Modes
  #1  
Unread 11th May, 2017, 09:53 PM
dizzy's Avatar
dizzy dizzy is offline
Rampage
 
Join Date: Apr 2012
Posts: 79
Default Graphics stuttering issue related to netspeed (video inside)

I've been suffering from stuttering graphics when playing online in UT ever since I upgraded my PC and can't find a solution.

It looks and feels a lot like what happens if you play with an uncapped high frame rate (like 300FPS+) but this issue is happening even though I'm using a frame rate limit and/or VSync.

It's almost certainly related to netspeed or UT's netcode because it's fine on some servers (like UK Insta which I think is a Windows server) but not on others (like my own BunnyTrack.net which is Linux).

It's also 100% not a problem if I play offline.

My normal setup:

• Windows 7 64-bit
• GTX 1080
• 165Hz monitor
• VSync disabled and GSync enabled
• Running D3D10 renderer with a 180 FPS cap

If I uncap the FPS I reach 800+ FPS and the game goes insane.

I have tried:

• Different renderers: D3D10, D3D9, D3D, OpenGL
• Different frame rate caps (100, 150, 180, 200 etc.)
• Different netspeeds (lower netspeeds like 5000 do reduce the stuttering but make me unable to connect to Nexgen/ACE/etc.)
• Disabling/Enabling VSync/GSync/ULMB etc.

I've even tried changing my Linux server settings but this didn't help, and other people don't seem to experience the problem.

Video:



Any ideas?
__________________
BunnyTrack.net: Great BT for Everyone
Reply With Quote
  #2  
Unread 12th May, 2017, 01:19 PM
admin admin is offline
Holy Shit!!
 
Join Date: Nov 2006
Location: France
Posts: 1,773
Default

you can also trying adding your cpu speed into your ut shortcut(right click it and click properties), so it would look something like this
C:\UnrealTournament\System\UnrealTournament.exe -cpuspeed=NUMBER

to find the exact number you can download a program called cpu-z or core temp and it will tell you.
so for example under control panel mine is set to 3.2ghz, but with the programs mentioned the exact number is 3231
-cpuspeed=3231



The future is
ACE
NewNet
XCEngine
__________________
Files for UT99 utfiles All new releases and updates are listed here All news
Most popular is UnrealTournament-V3 With over 8000 visits to date.It is an optimized UT99 to download.

Last edited by admin : 12th May, 2017 at 01:28 PM.
Reply With Quote
  #3  
Unread 13th May, 2017, 07:10 AM
dizzy's Avatar
dizzy dizzy is offline
Rampage
 
Join Date: Apr 2012
Posts: 79
Default

Thank you but it didn't help. I'm sure it must be network related because it's fine offline and some servers work fine.
__________________
BunnyTrack.net: Great BT for Everyone
Reply With Quote
  #4  
Unread 14th May, 2017, 09:35 AM
admin admin is offline
Holy Shit!!
 
Join Date: Nov 2006
Location: France
Posts: 1,773
Default

Stop your firewall and antivirus for a test.
If it's ok Make an exception for UT in the two.

This is for all server online or just yours linux one ?
__________________
Files for UT99 utfiles All new releases and updates are listed here All news
Most popular is UnrealTournament-V3 With over 8000 visits to date.It is an optimized UT99 to download.
Reply With Quote
  #5  
Unread 22nd May, 2017, 05:31 AM
dizzy's Avatar
dizzy dizzy is offline
Rampage
 
Join Date: Apr 2012
Posts: 79
Default

It's all online servers, although it is much better if ACE is installed. Probably because ACE limits the client's framerate to a reasonable level.

ACE doesn't completely remove the stuttering, but it makes it playable.

I'm convinced that this problem is related to high frame rates, even if the user has set a frame rate limit in their graphics preferences.

The problem seems to only be visible to players with a computer powerful enough to produce crazy frame rates (1000 FPS) when FPS is uncapped.
__________________
BunnyTrack.net: Great BT for Everyone
Reply With Quote
  #6  
Unread 23rd May, 2017, 11:32 AM
attaman attaman is offline
Forum Newcomer
 
Join Date: Nov 2016
Posts: 2
Default

I have absolutly the same shit stuttering.
And i have tried all settings, renders, fixes and so on.. Nothing help for 100%
As I have noticed, this stuttering caused by UTPure, so at servers without it I can play smooth with my 150 fps. For example newnet servers have built-in UTPure and it works fine and you can play with any fps there.
Try to use 80 fpslimit, this is the best value for servers with UTPure (when you set netspeed to 5000 you will have around 78 fpslimit, thats why it helped you).
So, there is only 3 options:
1. play with 80 fps
2. use newnet
3. try to find UTPure developer and ask him to fix it.
Reply With Quote
  #7  
Unread 24th May, 2017, 04:26 AM
2399Skillz 2399Skillz is offline
Super Moderator
 
Join Date: Jan 2004
Location: North Carolina
Posts: 2,238
Default

Have you tried running your framerate at 60?
__________________

UT-FILES.COM
Get your files
Reply With Quote
  #8  
Unread 25th May, 2017, 07:12 AM
lolo121 lolo121 is offline
Killing Spree
 
Join Date: Mar 2013
Posts: 29
Default

check if you have this problem in singleplayer mode also.
Reply With Quote
  #9  
Unread 30th May, 2017, 06:06 PM
isense's Avatar
isense isense is offline
Rampage
 
Join Date: Sep 2008
Location: Netherlands, Friesland
Posts: 58
Default

I've replied a few days ago in the first topic you made on our site as well.
1 thing is really valuable of knowledge, to rule out the causes:
Do you run your UT99 at 1 core, or at multiple cores ?
It explicitly needs to run at 1 core.

I don't read in your post, that you actually checked this.
Might be very handy, to still do that!

ACE can have problems capping your framerate if its running at multiple cores.
Such things are really important to rule out before changing server settings
or even starting thinking about other things.

Minimize the game
CTRL+SHIFT+ESC for taskmgr.
Check processes tab
Right-click unrealtournament.exe
Go to details
Right-click again
Set Affinity
Uncheck all cores.
Only keep CPU(0) checked.

*note in WIN7 and WIN8 8.1 this option won't be remembered by Windows, after you restart the process

Thats why i've included the multicorefix executable in our ClassicUT99 version.

Can you give an answer on these questions?
Not replying, won't narrow down the rootcause.
__________________
[align=center]http://www.classicut99.com[/align]





Last edited by isense : 30th May, 2017 at 06:10 PM.
Reply With Quote
  #10  
Unread 9th June, 2017, 04:32 PM
dizzy's Avatar
dizzy dizzy is offline
Rampage
 
Join Date: Apr 2012
Posts: 79
Default

Sorry for the long delay, but I've replied on your forum:

Quote:
OK! I did a grand experiment and can confirm that - basically - nothing makes a difference.

I installed a fresh copy of UT and then ran it using several different launchers/timing fixes.

All of the tests were performed with the same renderer (D3D10) with VSync off and the renderer's frame rate limit set to 180.

Fresh UT: stuttering is present, frame rate is 180 (limited)
Fresh UT with affinity manually set to one core: stuttering is present, frame rate is 180 (limited)
Fresh UT with dual core fix: stuttering is present, frame rate is 180 (limited)
Fresh UT with Launch by Hanfling: stuttering is NOT present but frame rate is capped at 65

So as you can see the issue is not related to CPU timing.

Also it's important to remember that when I play offline, there is no stuttering whatsoever so this has to be a netcode issue.
__________________
BunnyTrack.net: Great BT for Everyone
Reply With Quote
  #11  
Unread 11th June, 2017, 02:56 AM
2399Skillz 2399Skillz is offline
Super Moderator
 
Join Date: Jan 2004
Location: North Carolina
Posts: 2,238
Default

Pretty sure UT just doesn't like running past 60 FPS.
__________________

UT-FILES.COM
Get your files
Reply With Quote
  #12  
Unread 23rd June, 2017, 06:24 AM
zavateandu's Avatar
zavateandu zavateandu is offline
Dominating
 
Join Date: Nov 2010
Posts: 169
Default

i had it also once and took me over a month to find it,even i had some argue with my ISP about it and the problem was in a place you never beleive:i changed the mouse that was make the stuttering to be present.
this is just my 2 cents,maybe will help and just try it.
__________________
Reply With Quote
  #13  
Unread 28th November, 2017, 01:17 AM
dizzy's Avatar
dizzy dizzy is offline
Rampage
 
Join Date: Apr 2012
Posts: 79
Default

The issue was solved by installing NewNet on the server. So it was indeed related to UT's old netcode as I suspected.

Unfortuntately NewNet was not suitable for my server because it messed up various things in BunnyTrack maps, but it may be suitable for other servers.
__________________
BunnyTrack.net: Great BT for Everyone
Reply With Quote
  #14  
Unread 28th November, 2017, 08:39 AM
admin admin is offline
Holy Shit!!
 
Join Date: Nov 2006
Location: France
Posts: 1,773
Default

dizzy

I think you don't read your forum.
I ave post for BT Newnet.
__________________
Files for UT99 utfiles All new releases and updates are listed here All news
Most popular is UnrealTournament-V3 With over 8000 visits to date.It is an optimized UT99 to download.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 10:27 PM.


Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

All pages are copyright The Unreal Admins Page.
You may not copy any pages without our express permission.