You are an unregistered user, you can register here
Navigation

Information

Site

Donations
If you wish to make a donation you can by clicking the image below.


Site Sponsor

BeyondUnreal News

 
Go Back   The Unreal Admins Page > Forums > Hosted Forums > UTPure > UTPure - Client Side Hack Protection > General Anti-Cheat Discussion

Reply
Thread Tools Display Modes
  #1  
Unread 18th August, 2004, 01:40 PM
Eek Eek is offline
Forum Newcomer
 
Join Date: Jan 2004
Location: Copenhagen, Denmark
Posts: 8
Default PlayerPacks[] and Custom Models?

Hi;

I have a problem installing a custom skin on our server when Pure (7E) is enabled. Generally, skin packs work OK but this one adds a new model/mesh which might be the problem.

The skin in question is the famous Abbey-skin. When I add them ...
ServerPackages=6Abbey
ServerPackages=Abbeyskins
ServerPackages=AbbeySkins_666

... the following error is logged when people using the skin try to join:
ScriptLog: Attempted to use illegal skin from package abbeyskins_666 for Commando
ScriptLog: Failed to load abbeyskins_666.sydn1 so load CommandoSkins.cmdo1

I've tried adding a Pure PlayerPacks[] entry (according to the readme can this be used to allow custom skins, but there are not really any details given) putting various Abbey package names in there, to no avail.

Has anyone made this work? And what exactly are the names that go in in the PlayerPacks[] entries - e.g. the BP1 and BP4 names added are not evident from any of the ServerPackages, where do they come from?

Thanks in advance.
:b00m:Eek!
Reply With Quote
  #2  
Unread 18th August, 2004, 07:03 PM
Azura's Avatar
Azura Azura is offline
Holy Shit!!
 
Join Date: Apr 2003
Posts: 4,020
Default

Hi Eek,

Have you actually installed Bonus Pack 1 & 4 to your server ? If not I would do so as it adds some custom content that is used by a few maps and adds support for new models. I'm not sure why the abbey skin is causing a problem but it might be due to the absence of these.
__________________
How to feck up a perfectly good game:
UT (1999) = UnbelievableGameSoCoolIMustHelpBringNewPlayers Tournament
UT (2008) = Unreal ThrustMyPrivatePartsInYourFaceBish

And that's probably why UTIII was a relative flop. New game, same sh*thead players ^^.
Reply With Quote
  #3  
Unread 18th August, 2004, 07:28 PM
Eek Eek is offline
Forum Newcomer
 
Join Date: Jan 2004
Location: Copenhagen, Denmark
Posts: 8
Default

Yes, BP1+4 are installed, so that can't be it, unfortunately. I know another server admin who has the exact same problems with the Abbey skins on their server, and according to him disabling Pure (I think he uses 7C, I'm on 7E) makes it work, so it has to be Pure related. :|
Reply With Quote
  #4  
Unread 18th August, 2004, 08:52 PM
Just_Me Just_Me is offline
UTPure Admin
 
Join Date: Aug 2003
Posts: 457
Default

Have you installed the BP handlers packed with Pure and added the ServerPackages lines for those handlers.
Reply With Quote
  #5  
Unread 19th August, 2004, 12:51 AM
SkullKrusher SkullKrusher is offline
Dominating
 
Join Date: May 2004
Posts: 102
Default

Abbey is a tricky skin it has problems to begin with you should get the skin only working on your server then git it working with utpure then keep it working with your mods. good luck with it however it is location sensitive in the ini
Reply With Quote
  #6  
Unread 19th August, 2004, 12:49 PM
Eek Eek is offline
Forum Newcomer
 
Join Date: Jan 2004
Location: Copenhagen, Denmark
Posts: 8
Default

Quote:
Originally Posted by SkullKrusher
Abbey is a tricky skin it has problems to begin with you should get the skin only working on your server then git it working with utpure then keep it working with your mods. good luck with it however it is location sensitive in the ini
Well, I had to problems with the skin only with Pure. If I set bUTPureEnabled=False it works without any problems.

Enabling Pure causes the skin not to work causing a fallback to a default skin and the error message I posted logged.
Reply With Quote
  #7  
Unread 19th August, 2004, 12:50 PM
Eek Eek is offline
Forum Newcomer
 
Join Date: Jan 2004
Location: Copenhagen, Denmark
Posts: 8
Default

Quote:
Originally Posted by Just_Me
Have you installed the BP handlers packed with Pure and added the ServerPackages lines for those handlers.
Yes, tghe BP handler server packages are installed. Indeed, everything works as long as I set bUTPureEnabled=False but setting it to True causes the skin to fail.
Reply With Quote
  #8  
Unread 2nd August, 2008, 04:00 AM
{SLINKY {SLINKY is offline
Forum Newcomer
 
Join Date: Jul 2008
Posts: 10
Default

where can i dl them skins
Reply With Quote
  #9  
Unread 2nd August, 2008, 10:09 PM
[DANISH]TheDane's Avatar
[DANISH]TheDane [DANISH]TheDane is offline
Holy Shit!!
 
Join Date: May 2005
Location: Denmark
Posts: 688
Default

Here is my setup for the Pornstar server, it runs with the abby model and skins together with UTPure, never had an issue with that skin:

Code:
ServerActors=ActorCLP.ActorCLP
ServerPackages=SoldierSkins
ServerPackages=CommandoSkins
ServerPackages=FCommandoSkins
ServerPackages=SGirlSkins
ServerPackages=BossSkins
ServerPackages=Botpack
//ServerPackages=IUTDCv11
//ServerPackages=UTDCv20c
//ServerPackages=UTDCv20cdll
//ServerActors=UTDCv20c.SMain
//ServerActors=UTDCAMv11.SMain
ServerActors=AnthCheckerS_v138.ACActor
ServerPackages=AnthCheckerC_v138
ServerPackages=UTPureRC7G
ServerActors=UTPureRC7G.UTPureSA
ServerPackages=VAHandler7G
serverpackages=AntiTweakV42
ServerPackages=multimesh
ServerPackages=epiccustommodels
ServerPackages=EnhancedItems
ServerPackages=AdvancedModelSupport
ServerPackages=SkeletalChars
ServerPackages=KickIdlePlayers2
ServerPackages=MapVoteLA13
ServerPackages=AMLP_HaSm_v1b
ServerPAckages=Revenge
ServerActors=ServerAdds.ServerAdds
ServerActors=DanishUTv1s.AimWatcher
ServerActors=DanishUTv1s.ShadowTracker
ServerActors=DanishUTv1s.Rdisabler
ServerPackages=DanishUTv1c
ServerPackages=PornstarLogo
ServerPackages=6Abbey
ServerPackages=Abbeyskins
ServerPackages=AbbeySkins_Nude
ServerPackages=AbbeySkins_NudeAbbey
ServerPackages=Conni
ServerPackages=ConniSkins
ServerPackages=FCommandoSwanNue
ServerPackages=KingpinFemale
ServerPackages=LeelaVoice
ServerPackages=RetardGirl
ServerPackages=SgirlSkins_Nude
ServerPackages=WITCH
//ServerActors=UTStatsBeta4_2.UTStatsSA
//ServerPackages=UTSAccuBeta4_2
ServerPackages=AKAV6k
ServerActors=asc760.asc_server
ServerPackages=asc760
ServerPackages=asc7cc
I believe these packages are needed:
Code:
ServerPackages=multimesh
ServerPackages=epiccustommodels
ServerPackages=AdvancedModelSupport
ServerPackages=SkeletalChars
__________________
"Whoever undertakes to set himself up as a judge of Truth and Knowledge is shipwrecked by the laughter of the gods." - Albert Einstein.

Denne hjemmeside er en vittighed, humor er godt men dobbeltmoral er skidt
Reply With Quote
  #10  
Unread 18th August, 2008, 09:23 PM
Letylove49's Avatar
Letylove49 Letylove49 is offline
Holy Shit!!
 
Join Date: Mar 2005
Posts: 687
Default

warning : if you use le VAHandler you DOT NOT SETTING THE BP1 AND BP4 OR THE VA DON'T WORKING. THE BESTE VA IS VAHANDLER 7E

ServerActors=UTPureRC7E.UTPureSA
ServerPackages=UTPureRC7E
ServerPackages=VAHandler7E

[UTPureRC7E.UTPure]
bUTPureEnabled=True
Advertise=1
AdvertiseMsg=1
bAllowCenterView=False
CenterViewDelay=1.000000
bAllowBehindView=True
TrackFOV=0 (<<< here set to 0 or VA don't working)
bAllowMultiWeapon=True
bFastTeams=True
bUseClickboard=True
MinClientRate=5000
bAdvancedTeamSay=True
bHitSounds=True
bTeamHitSounds=False
ForceSettingsLevel=2
bNoLockdown=True
bWarmup=True
bCoaches=False
bAutoPause=True
ForceModels=0
ImprovedHUD=1
bDelayedPickupSpawn=False
PlayerPacks[0]=VA
PlayerPacks[1]=
PlayerPacks[2]=
PlayerPacks[3]=
PlayerPacks[4]=
PlayerPacks[5]=
PlayerPacks[6]=
PlayerPacks[7]=
bTellSpectators=True
bNoWeaponThrow=False
bForceDemo=False
__________________
<[MHA]>Letylove49 aka Shado170
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 10:09 PM.


Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

All pages are copyright The Unreal Admins Page.
You may not copy any pages without our express permission.