You are an unregistered user, you can register here
Navigation

Information

Site

Donations
If you wish to make a donation you can by clicking the image below.


Site Sponsor

BeyondUnreal News

 
Go Back   The Unreal Admins Page > Forums > Unreal Admins > Unreal Tournament 3 > UT3 Server - Beta Only

Reply
Thread Tools Display Modes
  #1  
Unread 21st November, 2007, 06:57 PM
dbixler dbixler is offline
Forum Newcomer
 
Join Date: Nov 2007
Posts: 3
Default Linux Server Issues

Well, I was able to start and get the server listed on my Ubuntu Fiesty Box. It was also successfully listed in the list of available servers. However, after about 5 minutes, it crashes. The process is still alive, but none of the in-game actions seem to work. I think it may be related to these lines when I start my server:

DevPhysics: Error (1) in file /home/icculus/projects/novodex-Icculus/novodex/SDKs/Physics/src/NpScene.cpp, line 712: Scene::createCompartment(): desc.isValid() fails!
DevPhysics: Error (1) in file /home/icculus/projects/novodex-Icculus/novodex/SDKs/Physics/src/NpScene.cpp, line 712: Scene::createCompartment(): desc.isValid() fails!


Anyhow, I created a script to launch my server. It looks like:


./ut3demo server vCTF-Suspense?GameMode=3?bIsDedicated=True?AdminPasswor d=xxxxx?ServerDescription=072000111000117000115000 10100003200010000010100003200008300011300011700010 5000100000?bShouldAdvertise=True?bIsLanMatch=False -Login=xxxxx -Password=xxxxx -unattended &


Anyone have any ways to fix those two Physix errors?
Reply With Quote
  #2  
Unread 21st November, 2007, 06:58 PM
dbixler dbixler is offline
Forum Newcomer
 
Join Date: Nov 2007
Posts: 3
Default

As a side note, I have this running on a dual core processor, I think an E6600. It consumes anywhere between 15 and 40% CPU time. I "tad" high I thought, but not totally unreasonable.
Reply With Quote
  #3  
Unread 21st November, 2007, 07:01 PM
dbixler dbixler is offline
Forum Newcomer
 
Join Date: Nov 2007
Posts: 3
Default

OH, one more thing. My server is behind a firewall. I had to redirect (at least) two ports. First was port 7777, that one was obvious. However, finding the OTHER port required this command:

netstat -pan | grep ut3

That showed me that the process was using port 7777 and 13000. Once I forwarded 13000, everything was hunky-dory, excepting, of course, the crash about 5 minutes into the game.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 10:25 AM.


Powered by vBulletin® Version 3.6.7
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

All pages are copyright The Unreal Admins Page.
You may not copy any pages without our express permission.