PDA

View Full Version : XMP Dedicated Server Error


DarkHelmet
15th January, 2004, 05:10 PM
I keep getting the "Commandlet server not found" when I try and run my server.

Here's the batch file I'm using:
:loopme
C:\U2XMP\SYSTEM\ucc.exe server XMP-Lowlands ini=Myserver1.ini log=server1.log
goto loopme

And here's my ini:
[URL]
Port=7777

[FirstRun]

[Engine.Engine]

[Core.System]

[Engine.GameEngine]
ServerActors=UWeb.WebServer

[WinDrv.WindowsClient]

[Engine.Player]

[ALAudio.ALAudioSubsystem]

[IpDrv.TcpNetDriver]

[IpDrv.HTTPDownload]
RedirectToURL=
ProxyServerHost=
ProxyServerPort=3128
UseCompression=True

[Engine.DemoRecDriver]

[Engine.GameReplicationInfo]
ServerName=Lan Pwnage XMP
MOTDLine1=Welcome to
MOTDLine2=LAN Pwnage
MOTDLine3=Prepare to be
MOTDLine4=Pwned
AdminName=DarkHelmet
AdminEmail=darkhelmet@<hidden>

[IpServer.UdpServerQuery]

[IpDrv.UdpBeacon]

[D3DDrv.D3DRenderDevice]

[PixoDrv.PixoRenderDevice]

[Engine.NullRenderDevice]

[Editor.EditorEngine]

[Engine.GameInfo]
MaxPlayers=16

[IpDrv.MasterServerLink]

[IpDrv.MasterServerUplink]
DoUplink=True
UplinkToGamespy=True
ServerBehindNAT=

[UWeb.WebServer]
bEnabled=True
ListenPort=8777

[U2WebAdmin.U2ServerAdmin]
AdminUsername=Andy
AdminPassword=jennaportsux

[Engine.LevelInfo]

[U2.MapListXMP]
Maps=XMP-Alcazar
Maps=XMP-FreeFall
Maps=XMP-Garden
Maps=XMP-Lowlands
Maps=XMP-NaKoja
Maps=XMP-Rampant
Maps=XMP-Sirocco
Maps=XMP-SunsetBeach

[U2.XMPGame]
RespawnDelaySeconds=15
bAllowBehindView=False
TimeLimit=45
TeamDamage=.5
bTeamAutobalance=False
PreMatchWait=0

[Engine.AccessControl]
IPPolicies[0]=ACCEPT,*
AdminPassword=xxxx
GamePassword=

QuikShot
22nd January, 2004, 11:19 PM
Problems have been reported with using the ini=*.ini parameter. You will need to remove this (and also possible your log=*.log parameter) to get the server to start.

If you want to run multiple servers from one folder, this does not currently seem to be possible. Downloading the new (70MB) dedicated server version should eliminate the need to run many servers from one folder :)

iCQ
9th February, 2004, 08:50 AM
Problems have been reported with using the ini=*.ini parameter. You will need to remove this (and also possible your log=*.log parameter) to get the server to start.

If you want to run multiple servers from one folder, this does not currently seem to be possible. Downloading the new (70MB) dedicated server version should eliminate the need to run many servers from one folder :)

I can use the log and ini command line options just fine... though i dont use a batch script but windows scripting.

Hey are you THE quickshot? (from jolt)

Rodmar
15th March, 2004, 01:47 PM
I do use a batch file and also added ini=*.ini log=*.log params.

No problem at all...