The Unreal Admins Page - Forums

The Unreal Admins Page - Forums (https://unrealadmin.org/forums/index.php)
-   General Chat (https://unrealadmin.org/forums/forumdisplay.php?f=177)
-   -   [Release] ACE v0.6q BETA (https://unrealadmin.org/forums/showthread.php?t=29821)

AnthraX 7th April, 2010 03:38 PM

[Release] ACE v0.6q BETA
 
2 Attachment(s)

Keep in mind that this is still a BETA. There are bugs! Use it at your own risk.
I would NOT recommend installing this on a server which you don't have full access to.


Most of the information (including a quick install guide) is included in the release package. It is not required to add any ACE settings to your server.ini file. ACE will use its standard settings by default and these standard settings will work fine on most servers. If you DO wish to alter any settings, please consult the full documentation on this url:

http://utgl.unrealadmin.org/ace/

Changelist is here:

http://utgl.unrealadmin.org/ACE/changes.txt

List of known issues is here:

http://utgl.unrealadmin.org/ACE/knownissues.txt

The next version (v0.7) is being tested in private now.

** EDIT **
Attached a new version of v0.6q to this post. The new version includes a new ACEIpDrv (with better performance) and a serverside actor that supports NAT routers. Clientside files are unchanged so it's safe to install the new version on top of the old version.

wIz4 7th April, 2010 04:45 PM

Awesome, thanks!

SoNY_scarface 7th April, 2010 05:00 PM

Quote:

Originally Posted by AnthraX (Post 153724)
I would NOT recommend installing this on a server which you don't have full access to.


Full access as in Shell/Box access?

Spank 7th April, 2010 05:01 PM

Sweet! Nice work (:

rork 7th April, 2010 06:01 PM

Good to see it finally being released, Great Job!

qwerty 7th April, 2010 06:03 PM

cool! I still wait for final release though :)

robbo98 7th April, 2010 06:36 PM

am i right in thinking this will auto update?

Genecom 7th April, 2010 06:40 PM

Quote:

Originally Posted by robbo98 (Post 153732)
am i right in thinking this will auto update?

ACE doesn't update it's core files at the moment, only the file definitions.
It will however inform the admin when a new version is available, but it must be installed manually.

( Upload to server, remove current ACE server actors, SAVE, restart server and it will auto install latest version )

TSQ 7th April, 2010 07:03 PM

My first catch :)

ScriptLog: [ACEv06q]: +---------------------------------------------------------------+
ScriptLog: [ACEv06q]: | Player Kick |
ScriptLog: [ACEv06q]: +---------------------------------------------------------------+
ScriptLog: [ACEv06q]: PlayerName...: ADRIAN
ScriptLog: [ACEv06q]: PlayerIP.....: 190.212.xxx.xxx
ScriptLog: [ACEv06q]: OS...........: Microsoft Windows XP x86 (Version: 5.1.2600)
ScriptLog: [ACEv06q]: CPU..........: Pentium(R) Dual-Core CPU E5300 @ 2.60GHz
ScriptLog: [ACEv06q]: CPUSpeed.....: 2591.096211 Mhz Measured - 2592.867743 Mhz Reported
ScriptLog: [ACEv06q]: NICDesc......: Realtek RTL8102/8103/8136 Family PCI-E FE NIC - Minipuerto del administrador de paquetes
ScriptLog: [ACEv06q]: MACHash......: 0A6EE7C3EFB5978F49659DD907085F62
ScriptLog: [ACEv06q]: UTVersion....: 436
ScriptLog: [ACEv06q]: Renderer.....: D3DDrv.D3DRenderDevice
ScriptLog: [ACEv06q]: SoundDevice..: Galaxy.GalaxyAudioSubsystem
ScriptLog: [ACEv06q]: CommandLine..: <none>
ScriptLog: [ACEv06q]: KickReason...: VTable Hook
ScriptLog: [ACEv06q]: TimeStamp....: 07-04-2010 / 13:40:45
ScriptLog: [ACEv06q]: +---------------------------------------------------------------+
ScriptLog: [ACEv06q]: | Extra Info |
ScriptLog: [ACEv06q]: +---------------------------------------------------------------+
ScriptLog: [ACEv06q]: ModuleHandle.: 0x10300000
ScriptLog: [ACEv06q]: ModuleName...: Engine.dll
ScriptLog: [ACEv06q]: HookedObject.: Font Engine.SmallFont
ScriptLog: [ACEv06q]: HookedEntry..: 3
ScriptLog: [ACEv06q]: Found........: 0x20813340 -> Unknown!Unknown+0x0000
ScriptLog: [ACEv06q]: +---------------------------------------------------------------+
ScriptLog: [ACEv06q]: | Screenshot Status |
ScriptLog: [ACEv06q]: +---------------------------------------------------------------+
ScriptLog: [ACEv06q]: Success......: FALSE
ScriptLog: [ACEv06q]: Error........: Timeout
ScriptLog: [ACEv06q]: +---------------------------------------------------------------+

Genecom 7th April, 2010 07:14 PM

Nice one, it seems to be a quite popular cheat that's been undetected before. On screenshots it looks very similar to HH/Radar and it's a legit catch.

TSQ 7th April, 2010 07:26 PM

Nice... I tried the screenshots a few times and they all timed out, should I make any changes here ?

SShotTimeOut=20.000000

AnthraX 7th April, 2010 07:28 PM

Quote:

Originally Posted by TSQ (Post 153737)
Nice... I tried the screenshots a few times and they all timed out, should I make any changes here ?

SShotTimeOut=20.000000

Screenshots are broken in v0.6q. I've fixed it in v0.7

TSQ 7th April, 2010 07:29 PM

Ok, good deal!

kawaii 7th April, 2010 08:07 PM

Nice to see a release anth. The changelog for the upcomming v0.7 also looks great.
Let all the win 7 users return :-)

[DoC]Str!Ker 7th April, 2010 08:13 PM

Finally I can go for a game of UT again 8-)
Cheers

nogginBasher 7th April, 2010 08:27 PM

Linux players grab this, extract the files, and put them in your System folder: http://utgl.unrealadmin.org/NPLoader/v15e/Linux.tar.gz

TSQ 7th April, 2010 08:28 PM

2nd catch of the day...


[ACEv06q]: +---------------------------------------------------------------+
[ACEv06q]: | Player Kick |
[ACEv06q]: +---------------------------------------------------------------+
[ACEv06q]: PlayerName...: Osmon
[ACEv06q]: PlayerIP.....: 195.22.xxx.xx
[ACEv06q]: OS...........: Microsoft Windows XP x86 (Version: 5.1.2600)
[ACEv06q]: CPU..........: Intel(R) Pentium(R) 4 CPU 2.40GHz
[ACEv06q]: CPUSpeed.....: Mhz Measured - 2393.995198 Mhz Reported
[ACEv06q]: NICDesc......: WAN (PPP/SLIP) Interface
[ACEv06q]: MACHash......: 577D47B146A97F8E32ACF1A55773EE0B
[ACEv06q]: UTVersion....: 436
[ACEv06q]: Renderer.....: SoftDrv.SoftwareRenderDevice
[ACEv06q]: SoundDevice..: Galaxy.GalaxyAudioSubsystem
[ACEv06q]: CommandLine..: -no3dsound -nohard -nohard -noddraw -defaultres -nommx -nokni -nok6 -nojoy
[ACEv06q]: KickReason...: Illegal Package found during Initial Check
[ACEv06q]: TimeStamp....: 07-04-2010 / 15:00:05
[ACEv06q]: +---------------------------------------------------------------+
[ACEv06q]: | Extra Info |
[ACEv06q]: +---------------------------------------------------------------+
[ACEv06q]: PackageName..: Engine
[ACEv06q]: PackagePath..: ../System/Engine.u
[ACEv06q]: PackageSize..: 1149858 bytes
[ACEv06q]: PackageHash..: 2D7EDC1B20EC674D28573CC2D13C67D5
[ACEv06q]: PackageVer...: Unknown
[ACEv06q]: +---------------------------------------------------------------+
[ACEv06q]: | Screenshot Status |
[ACEv06q]: +---------------------------------------------------------------+
[ACEv06q]: Success......: FALSE
[ACEv06q]: Error........: Timeout
[ACEv06q]: +---------------------------------------------------------------+

Genecom 7th April, 2010 08:48 PM

Worth mentioning that there are cases like above that arn't definitive cheats.
These can be corruptions of legit files quite similar to those kicked out by UTDC when they didn't match the ones specified in MD5 checks.

Also it would seem that eastern countries like russia have their own setup of Engine.u, utmenu.u and erm, think it was one more. However we havn't been succesful in obtaining these to verify if it's a special eastern version - tho there is no official release of UT that isn't included in the whitelists so might be custom spread through torrents or the likes.

I'd treat those false if hash can't be found on the interwebz, being confirmed belonging to a hacked package - or if paranoid ban.
Don't see a need for banning as they won't get on server anyways.

-=CoN=-Strych9 7th April, 2010 11:05 PM

Thank you!

shadow_knight 7th April, 2010 11:42 PM

critical error
 



bear with me i have never posted here before when i loaded the ace program and restarted the server i get a critical error and ut shuts down more than one of us got this only thing i noticed is it moved some of my actor lines below the server packages lines when i shut the loader off it works fine any ideas


All times are GMT +1. The time now is 09:12 PM.

 


All pages are copyright The Unreal Admins Page.
You may not copy any pages without our express permission.