You are an unregistered user, you can register here
Navigation

Information

Site

Donations
If you wish to make a donation you can by clicking the image below.


 
Go Back   The Unreal Admins Page > Forums > Unreal Admins > Unreal Tournament 3 > UT3 Server - Windows Specific

Reply
Thread Tools Display Modes
  #1  
Unread 24th November, 2007, 09:33 PM
SunMan's Avatar
SunMan SunMan is offline
Rampage
 
Join Date: Oct 2006
Location: Bern / Switzerland
Posts: 52
Default Settings for unattended UT3 Servers

Hello Admins

maybe it helps... I have 4 servers running on Windows Server 2003. For each I have a directory - see the GameINI= and EngineINI= parameters. Beta-Patch101 is running. You need for each gametype a unique login - see LOGIN= parameter.

The following ports are open in the firewall:

Code:
TCP 8777
TCP 9777
UDP 13000
UDP 6500-65xx
And of course ut3.exe
Command lines:

Server-1 (CTF)

Code:
ut3.exe server CTF-Hydrosis?Game=UTGameContent.UTCTFGame_Content?GameMode=1?numplay=8?MinNetPlayers=1?bShouldAdvertise=True?bIsDedicated=True?TimeLimit=20?GoalScore=5?AdminPassword=*** -configsubdir=Server-CTF -Login=SUTS-SERVER1 -Password=*** -log=..\Logs\Server-CTF.log -port=7777 -multihome=193.138.213.214 -nohomedir -unattended
Server-2 (DM)

Code:
ut3.exe server DM-Deck?Game=UTGame.UTDeathmatch?GameMode=0?numplay=8?MinNetPlayers=1?bShouldAdvertise=True?bIsDedicated=True?TimeLimit=20?GoalScore=30?AdminPassword=*** -configsubdir=Server-DM -Login=SUTS-SERVER2 -Password=*** -log=..\Logs\Server-DM.log -port=8888 -multihome=193.138.213.214 -nohomedir -unattended
Server-3 (vCTF)

Code:
ut3.exe server vCTF-Suspense?Game=UTGameContent.UTVehicleCTFGame_Content?GameMode=3?numplay=8?MinNetPlayers=1?bShouldAdvertise=True?bIsDedicated=True?TimeLimit=20?GoalScore=5?AdminPassword=*** -configsubdir=Server-VCTF -Login=SUTS-SERVER3 -Password=*** -log=..\Logs\Server-vCTF.log -port=5555 -multihome=193.138.213.214 -nohomedir -unattended
Server-4 (TDM)

Code:
server DM-CarbonFire?Game=UTGame.UTTeamGame?GameMode=4?numplay=8?MinNetPlayers=1?bShouldAdvertise=True?bIsDedicated=True?TimeLimit=80?GoalScore=5?AdminPassword=*** -configsubdir=Server-TDM -Login=SUTS-SERVER4 -Password=*** -log=..\Logs\Server-TDM.log -port=9999 -multihome=193.138.213.214 -nohomedir -unattended
*** remark

removed the -EngineINI and -GameINI to -configsubdir=
The -configsubdir will be in the UTGame/Config directory

added the ?numplay= parameter for bots
__________________
Greetings from Switzerland
[SU+S]SunMan (Peter)

Last edited by SunMan : 1st December, 2007 at 04:52 PM. Reason: added TDM server (fixed DM command line)
Reply With Quote
  #2  
Unread 25th November, 2007, 01:42 AM
modulstyle's Avatar
modulstyle modulstyle is offline
Rampage
 
Join Date: Mar 2005
Location: Germany
Posts: 92
Default

Servers running nice! With these settings everybody should be able to set up an dedi machine
Reply With Quote
  #3  
Unread 25th November, 2007, 09:32 AM
Art_illery Art_illery is offline
Killing Spree
 
Join Date: Oct 2007
Posts: 24
Default

Thanks alot, we managed to bring up our first working Dedicated Server yesterday evening on a Virtual Machine we installed just for the UT3 Windows Server on our native Linux Host (Honestly we hate this configuration, we don´t like to be forced to use a Windows Virtual Machine in order to get a Dedicated Server running, but well, we can´t do anything else right now, but it cost us tons of nerves, and the image of EPIC Games that we had in our minds took a huge blow. Shame on EPIC for forcing us to do it this way!)

These Lines will help me a lot today, when i am setting up some more Gameservers on this Win2003 Virtual Machine.
Reply With Quote
  #4  
Unread 25th November, 2007, 10:57 AM
Art_illery Art_illery is offline
Killing Spree
 
Join Date: Oct 2007
Posts: 24
Default

I absolutely HATE Windows, i am trying right now to get multiple Servers working with your command lines, but my console keeps Crashing. And Of course Windows closes the Console right after the error which is causing this occurs, so that i have no chance of finding out the "easy" way, what i am doing wrong here.
This is just so typical of Windows. I am gonna burn down Microsoft and it´s ****** lame Shithead OS.
Why oh why can´t this ****** console stay open just like it is in other OS?

This is just sooooooooooooooooo non professional and absolutely mindbloggingly stupid i can´t stop raging about it.

Who on earth with any semi-decent knowledge about how computers work would ever use Windows as a Server OS? Are people who do that just soooo lazy, that they don´t care about usability?

Sorry, might be really way off commentary, but i feel like exploding here right now. And i need some ventilation in order to not kill my PC equipment in rage

Question @ SunMan: Where did you locate your Engine.ini and Game.ini exactly, and where did you create your Logs directory, i think that might be the issue for me here. ATM i have located those Files under C:\Documents and Settings\...\UTGame\Config\Server-Warfare\UTEninge.ini.

Last edited by Art_illery : 25th November, 2007 at 11:02 AM.
Reply With Quote
  #5  
Unread 25th November, 2007, 12:09 PM
Art_illery Art_illery is offline
Killing Spree
 
Join Date: Oct 2007
Posts: 24
Default

OK, i got it to work, finally.

I created some directories at C:\Documents and Settings\...\UTGame\Config\ named C:\Documents and Settings\...\UTGame\Config\Server-Warfare\ and C:\Documents and Settings\...\UTGame\Config\Server-CTF\ and copied the UTEngine.ini and UTGame.ini over there and edited them.

I deleted the -nohomedir part of your Command line, so that the UT3 Server would use the "C:\Documents and settings\...\UTGame\" Path for searching the appropriate INIs and writing out the Logs.
I also changed the -EngineINI=UTGame\Config\Server-TDM\Engine.ini to -EngineINI=..\UTGame\Config\Server-Warfare\UTEngine.ini

This did the trick for me!

Now the Servers are starting and finally after more than one month of painful information gathering, trials and errors and countless hours of my freetime wasted, i am starting to have it all configured and running in the most basic way that i can live with.

But everyone who has been through this whole ordeal of UT3 Server setup will surely concur, that it wasn´t a very pleasant ride.

Finally now i am able to put my focus on some finetuning and stuff instead of just getting the damn thing to work.

* Art_illery prays that there won´t be any more bad surprises which act as showstoppers for those UT3 Servers.

Last edited by Art_illery : 25th November, 2007 at 12:12 PM.
Reply With Quote
  #6  
Unread 25th November, 2007, 01:21 PM
SunMan's Avatar
SunMan SunMan is offline
Rampage
 
Join Date: Oct 2006
Location: Bern / Switzerland
Posts: 52
Default

Quote:
Originally Posted by Art_illery View Post
OK, i got it to work, finally.


You're right with the My Documents things.. but I hate this. For a dedicated server it is mutch easier to have the configs on that place, who I like it.
Good look!
__________________
Greetings from Switzerland
[SU+S]SunMan (Peter)
Reply With Quote
  #7  
Unread 1st December, 2007, 05:02 PM
ØldSt¥Le ØldSt¥Le is offline
Forum Newcomer
 
Join Date: Jan 2006
Posts: 3
Default

Hi there Sunman,

I have tried to put up a second server...using your method but i can't get it to work

I'm running windows server 2003
I tried everything art illery was talking about to..but my second server just starts up with same config as first

I just can't get it to use the C:\Documents and Settings\...\UTGame\Config\UC-Server ini files

plz help...if you need more info or config thingy's ask me

BTW my first server runs without any problems.

Greetz ØldSt¥Le

server1

Code:
@echo off
:SERVER
UT3 server WAR-Torlan?GameMode=2?bAllowMapVoting=true?bShouldAdvertise=True?bIsDedicated=True?PureServer=1?GoalScore=1?TimeLimit=15?Game=UTGameContent.UTOnslaughtGame_Content?AdminPassword=***?MaxPlayers=16?numplay=0?MaxCustomChars=16 -EngineINI=..\UTGame\Config\UC-Server\UTEngine.ini -GameINI=..\UTGame\Config\UC-Server\UTGame.ini -Login=*** -Password=*** -log=..\Logs\UC-Server.log -port=7877 -multihome=217.21.146.75 -unattended
goto SERVER
server2

Code:
@echo off
:SERVER
UT3 server DM-Deck?GameMode=0?bAllowMapVoting=true?bShouldAdvertise=True?bIsDedicated=True?PureServer=1?GoalScore=30?TimeLimit=15?Game=UTGame.UTDeathmatch?AdminPassword=***?MaxPlayers=16?numplay=0?MaxCustomChars=16 -EngineINI=..\UTGame\Config\UC-Server2\UTEngine.ini -GameINI=..\UTGame\Config\UC-Server2\UTGame.ini -Login=*** -Password=*** -log=..\Logs\UC-Server2.log -port=7977 -multihome=217.21.146.75 -unattended
goto SERVER
I also tried your edited thingy with -configsubdir..still starts as warfare server :S

Last edited by ØldSt¥Le : 1st December, 2007 at 05:06 PM. Reason: tried new edit sunman posted
Reply With Quote
  #8  
Unread 1st December, 2007, 11:47 PM
Symbioth Symbioth is offline
Forum Newcomer
 
Join Date: Nov 2005
Posts: 1
Default

Do I need to open more query ports if I run multiple servers or do all servers just use the 6500 query port?

If I use the -nohomedir command does it then use the ini files in the installed directory e.g. C:\Program Files\etc... or does it always use the mydocuments dir?
Reply With Quote
  #9  
Unread 2nd December, 2007, 03:02 AM
Rewind{KDS} Rewind{KDS} is offline
Forum Newcomer
 
Join Date: Jun 2004
Posts: 11
Default

Quote:
Originally Posted by Symbioth View Post
Do I need to open more query ports if I run multiple servers or do all servers just use the 6500 query port?

If I use the -nohomedir command does it then use the ini files in the installed directory e.g. C:\Program Files\etc... or does it always use the mydocuments dir?
Starting with the beta patch, query ports are assigned starting at 6500 incrementing by 100 if the port is not available.

Yes, the -nohomedir switch forces servers to use the ini files in the config folder of the game install.

I suggest using the following:

-nohomedir
(forces the servers to use the install directory instead of My Documents...)

-configsubdir=serverfoldername
(This will create a folder under ..\config\? so each server instance can have it's own ini files)

-queryport=XXXX
(Needs to be different for each server and open port. This way you know which query port each server is on.)

-unattended
(prevents servers from rewriting ini, MUST BE LAST in startup commandline)
Reply With Quote
  #10  
Unread 2nd December, 2007, 02:25 PM
Seek Seek is offline
Forum Newcomer
 
Join Date: Dec 2007
Location: Switzerland
Posts: 1
Default

Hmm, it looks like im too stupid to make an ut3 Server...
I have an Windows 2003 Server and the UT3 dedicated Files with patch 1.01 installed on D:/GameServer/UT3
I read some threads and forums and tried many things but im not able to create a server. I just want to have a easy batch file to start a Server.
What to i have to write in the batch file to start a normal TDM Server? It would be great if someone could help me
Reply With Quote
  #11  
Unread 2nd December, 2007, 02:56 PM
flakPT flakPT is offline
Forum Newcomer
 
Join Date: Feb 2005
Posts: 4
Default

Quote:
Originally Posted by Seek View Post
Hmm, it looks like im too stupid to make an ut3 Server...
I have an Windows 2003 Server and the UT3 dedicated Files with patch 1.01 installed on D:/GameServer/UT3
I read some threads and forums and tried many things but im not able to create a server. I just want to have a easy batch file to start a Server.
What to i have to write in the batch file to start a normal TDM Server? It would be great if someone could help me
1.Open ports 6500, 7777 and 13000. Be sure to install Patch beta1.

2. Use this commandline:

ut3.exe server DM-Deck?Game=UTGame.UTTeamGame?GameMode=4?bShouldAdve rtise=true?bUsesStats=True?bIsDedicated=True?Score Limit=0?TimeLimit=20?MaxPlayers=8?bAllowJoinInProg ress=True?numplay=0?Mutator=NoRedeemer.MutNoRedeem er,UTGame.UTMutator_WeaponsRespawn?AdminPassword=X XX -log=tdm-server.log -login=XXX -password=XXX -nohomedir -unattended

replace XXX with your stuff.

3. Download the NoRedeemer mutator (search EPIC forums), put the NoRedeemer.u file inside UT3Server\UTGame\CookedPC, and the UTNoRedeemer.ini inside UTGame\Config.

4. Edit UT3Server\UTGame\Config\UTGame.ini and change the server name. Under the [UTGame.UTGame] section, be sure to have this:

bAllowMapVoting=True
VoteDuration=45
GameSpecificMapCycles=(GameClassName="UTTeamGame", Maps=("DM-Arsenal","DM-Sanctuary","DM-Deck","DM-Defiance","DM-Deimos","DM-Diesel","DM-Gateway","DM-HeatRay","DM-RisingSun","DM-Sentinel","DM-ShangriLa"))

5. Run the bat file.

Congratulations, you now have a TDM 4v4 weapon stay off, no redeemer, map voting, 20 minutes, no score limit server working and connectable from the server browser.

PS: the -nohomedir makes the game forget about the files in your My documents folder, so make sure you do all your ini edits in UTGame\Config\UTGame.ini.

Last edited by flakPT : 2nd December, 2007 at 03:04 PM.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT +1. The time now is 03:17 AM.


 

All pages are copyright The Unreal Admins Page.
You may not copy any pages without our express permission.